Requirements

In order to successfully use SciDAVis, you need the following libraries:

Qt >= 4.2

SciDAVis uses the Qt toolkit. Version 4.2 or above is needed. It provides the necessary dynamic libraries to run the SciDAVis binaries and important tools to compile it.

Qwt

You need to install the Qwt library version 5.0.0 or above. It is recommended to use the latest release. Qwt must be compiled with Qt 4.x.

muParser

You also need the muParser library 1.28 or later.

liborigin

The latest version of the liborigin is required for the import of Origin OPJ project files.

Qwtplot3d

The 3D plots in SciDAVis make use of qwtplot3d. The library and must be available in version 0.2.6 or higher.

GSL

Furthermore, the GNU Scientific Library (GSL) (1.8 or later) must be installed on your system.

Zlib

Additionally, zlib >=1.2.3 is required. Since this is also a requirement of Qt, installing Qt should fullfill this requirement on most systems.

Python scripting

If you want to use Python expressions and scripts, make sure you have the following additional dependencies installed: Python >=2.5, SIP >=4.5.2, PyQt >=4.2. Other versions as those indicated above may or may not work.